Jama Connect performance degradation

Incident Report for Jama Software

Resolved

The Jama Software engineering team has identified and resolved the performance degradation issue. We will continue to monitor the situation but expect no further disruptions.
Posted 7 months ago. Sep 10, 2024 - 09:06 PDT

Investigating

Some customers have reported degradation to the performance of their Jama Connect instance. Our team has been notified and is investigating the issue.

As we continue to monitor performance, we will update this site with the latest information. We apologize for this interruption.
Posted 7 months ago. Sep 10, 2024 - 08:35 PDT
This incident affected: Americas (Connect).